Cannot attach to LODA

Questions and Answers : Bugs : Cannot attach to LODA
Message board moderation

To post messages, you must log in.

AuthorMessage
[AF>Le_Pommier] Jerome_C2005

Send message
Joined: 13 May 22
Posts: 11
Credit: 374,521
RAC: 11,883
Message 513 - Posted: 23 Jul 2022, 22:45:40 UTC
Last modified: 23 Jul 2022, 22:46:19 UTC

Hi

I had one small debian host crunching some LODA tasks but it seems it can't connect to the project, I just tried to add a debian VM on my mac to LODA and I get
Sun 24 Jul 2022 12:23:07 AM CEST |  | [error] Bad signature for URL https://boinc.loda-lang.org/loda/

If I try to ping from both hosts

root@xxx# ping https://boinc.loda-lang.org/loda/
ping: https://boinc.loda-lang.org/loda/: Name or service not known

and if I ping directly from my mac

jerome@imac-de-jerome projects % ping https://boinc.loda-lang.org/loda/ 
ping: cannot resolve https://boinc.loda-lang.org/loda/: Unknown host

But I'm here on the server, posting... so what's wrong ?
ID: 513 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Christian Krause
Project administrator

Send message
Joined: 9 May 22
Posts: 199
Credit: 194,242
RAC: 1,826
Message 515 - Posted: 24 Jul 2022, 12:29:01 UTC - in response to Message 513.  

If you use ping, it should be only the hostname, like this:
ping boinc.loda-lang.org

Can you please check if accessing it via curl works?
curl https://boinc.loda-lang.org/loda/
ID: 515 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
[AF>Le_Pommier] Jerome_C2005

Send message
Joined: 13 May 22
Posts: 11
Credit: 374,521
RAC: 11,883
Message 516 - Posted: 24 Jul 2022, 23:08:26 UTC

OK you are right the ping is OK now, however I cannot attach the machine that is not attached :

Mon 25 Jul 2022 01:05:42 AM CEST |  | [error] Bad signature for URL https://boinc.loda-lang.org/loda/
ID: 516 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Christian Krause
Project administrator

Send message
Joined: 9 May 22
Posts: 199
Credit: 194,242
RAC: 1,826
Message 517 - Posted: 25 Jul 2022, 21:34:37 UTC - in response to Message 516.  

Can you please check if this command works?

curl -I https://boinc.loda-lang.org/loda/
ID: 517 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
[AF>Le_Pommier] Jerome_C2005

Send message
Joined: 13 May 22
Posts: 11
Credit: 374,521
RAC: 11,883
Message 523 - Posted: 26 Jul 2022, 20:46:09 UTC

Voila

curl -I https://boinc.loda-lang.org/loda/
HTTP/1.1 200 OK
Date: Tue, 26 Jul 2022 20:42:54 GMT
Server: Apache/2.4.29 (Ubuntu)
Expires: Mon, 26 Jul 1997 05:00:00 UTC
Last-Modified: Tue, 26 Jul 2022 20:42:54 UTC
Cache-Control: no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Content-Type: text/html; charset=utf-8

The expiration date is... old, isn't it ?
ID: 523 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Christian Krause
Project administrator

Send message
Joined: 9 May 22
Posts: 199
Credit: 194,242
RAC: 1,826
Message 524 - Posted: 27 Jul 2022, 17:29:55 UTC - in response to Message 523.  

The output looks fine. I'm not aware of any certifictae problems that would explain the error. I also tried detaching and attaching and it worked finr for me. Not sure how to help :(
ID: 524 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
[AF>Le_Pommier] Jerome_C2005

Send message
Joined: 13 May 22
Posts: 11
Credit: 374,521
RAC: 11,883
Message 525 - Posted: 28 Jul 2022, 11:45:09 UTC

Ah ok I thought the expiration date would have something to do with it, I don't think I'll have time to test anything else (maybe boinc version ? etc) before I go on holidays this weekend so it'll have to wait end of August.

Thanks anyway, I'll keep you posted if some advances are made.
ID: 525 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
[AF>EDLS]zOU
New member

Send message
Joined: 24 Sep 22
Posts: 12
Credit: 625,791
RAC: 41,407
Message 566 - Posted: 24 Sep 2022, 9:06:40 UTC

[error] Bad signature for URL https://boinc.loda-lang.org/loda/
same error today on all machines
ID: 566 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
[AF] Hydrosaure
New member

Send message
Joined: 24 Sep 22
Posts: 3
Credit: 548,119
RAC: 39,334
Message 567 - Posted: 24 Sep 2022, 10:44:23 UTC

I'm having the same issue over here.


hydro@boinc-vm:~$ curl -I https://boinc.loda-lang.org/loda/
HTTP/1.1 200 OK
Date: Sat, 24 Sep 2022 09:59:28 GMT
Server: Apache/2.4.29 (Ubuntu)
Expires: Mon, 26 Jul 1997 05:00:00 UTC
Last-Modified: Sat, 24 Sep 2022 09:59:28 UTC
Cache-Control: no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Content-Type: text/html; charset=utf-8
ID: 567 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Christian Krause
Project administrator

Send message
Joined: 9 May 22
Posts: 199
Credit: 194,242
RAC: 1,826
Message 568 - Posted: 24 Sep 2022, 15:03:00 UTC - in response to Message 567.  

I don't get any certificate errors, also not with external tools:
https://www.sslshopper.com/ssl-checker.html#hostname=https://boinc.loda-lang.org
Can you maybe restart your machine and retry?
ID: 568 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
[AF] Hydrosaure
New member

Send message
Joined: 24 Sep 22
Posts: 3
Credit: 548,119
RAC: 39,334
Message 569 - Posted: 25 Sep 2022, 7:46:33 UTC

Did try to restart...
Did update de ca-bundle.crt BOINC uses...

...still the same.

I get this behavior on like 7 different computers, mostly running Ubuntu 20.04 LTS (there is also one on 22.04 LTS).

What signature are we actually talking about?
Is it really related to ssl ? couldn't it be something else ?
ID: 569 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
[AF] Hydrosaure
New member

Send message
Joined: 24 Sep 22
Posts: 3
Credit: 548,119
RAC: 39,334
Message 571 - Posted: 25 Sep 2022, 8:57:37 UTC - in response to Message 569.  

I'm using an account manager; it could be the problem comes from there.
ID: 571 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Christian Krause
Project administrator

Send message
Joined: 9 May 22
Posts: 199
Credit: 194,242
RAC: 1,826
Message 574 - Posted: 25 Sep 2022, 11:32:50 UTC - in response to Message 571.  

Would you be able to test attaching the project directly to one of your clients? If that works, then I would assume it is an issue with the account manager.
ID: 574 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Christian Krause
Project administrator

Send message
Joined: 9 May 22
Posts: 199
Credit: 194,242
RAC: 1,826
Message 575 - Posted: 25 Sep 2022, 12:17:18 UTC - in response to Message 574.  

I just tried it out an account manager (BAM) and it worked for me. Can you please share more logs from the Event Log?
ID: 575 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
[AF>Le_Pommier] Jerome_C2005

Send message
Joined: 13 May 22
Posts: 11
Credit: 374,521
RAC: 11,883
Message 576 - Posted: 25 Sep 2022, 17:34:45 UTC

Several other members of l'AF are having the same issue.

We now think this is linked to the use of SAM (not BAM) account manager.

By adding the project manually on linux box it works

boinccmd --project_attach https://boinc.loda-lang.org/loda/ <key>
ID: 576 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
[AF>Le_Pommier] Jerome_C2005

Send message
Joined: 13 May 22
Posts: 11
Credit: 374,521
RAC: 11,883
Message 579 - Posted: 25 Sep 2022, 18:44:29 UTC

Sebastien just mentioned that he identified and fixed the issue for SAM.

For those having the issue : please test !

Thanks !
ID: 579 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Questions and Answers : Bugs : Cannot attach to LODA

©2022 LODA Language